您现在的位置:首页 >> 电脑网络 >> 交换网络 >> 内容

OSSH免费版华为Portal对接华为9303交换机示例说明

时间:2014/3/18 20:12:02 点击:

  核心提示: 近期收到一个用户的投稿,是关于OSSH免费版Portal系统对接华为93系列交换机的案子,现将详细情况进行说明,希望能够帮助到各位。测试设备:华为9303为测试交换机,华为2700为汇聚交换机...
近期收到一个用户的投稿,是关于OSSH免费版Portal系统对接华为93系列交换机的案子,现将详细情况进行说明,希望能够帮助到各位。

测试设备:

华为9303为测试交换机,华为2700为汇聚交换机,OSSH免费版Portal,AP,PC,手机。

测试目的:

OSSH免费版Portal系统能够对接华为9303交换机,并实现Portal认证上网。

网络环境:

交换机配置:

<HW9303>display current-configuration

#

!Software Version V100R006C00SPC800

sysname HW9303

#

super password level 3 simple aaa

#

stp mode rstp

stp enable

#

domain isp1

#

dhcp enable

#

undo http server enable

#

dba-profile default0 type3 assure 40000 max 80000

#

diffserv domain default

#

//添加对接的radius的认证域配置

radius-server template rd1 //创建radius域名称为 rd1

radius-server shared-key cipher O'W3[_\M"`#Q=^Q`MAF4<1!! //设置两设备之间的radius通信密钥

radius-server authentication 182.40.89.2 1812 //设置radius认证地址和认证端口号

radius-server accounting 182.40.89.2 1813 //设置radius记账地址和记帐端口号

radius-server retransmit 2

undo radius-server user-name domain-included //不使用域名支持

#

line-profile default0

#

service-profile default0

undo fec-switch enable

#

web-auth-server abc //创建一个名称为abc的WEB认证服务

server-ip 182.40.89.2 //设置PORTAL服务器的地址

port 50100 //设置服务端口

shared-key cipher O'W3[_\M"`#Q=^Q`MAF4<1!! //设置对接PORTAL的对接密钥

url http://182.40.89.2:8080/login.jsp //认证的弹出页面访问地址

#

drop-profile default

#

vlan 250

description Guanli-vlan

#

ip pool 1 //创建一个名称为1的IP地址池

gateway-list 182.40.89.1 //用户获得的网关地址

network 182.40.89.0 mask 255.255.255.128 //用户获得的地址段

excluded-ip-address 182.40.89.2 //排除的IP地址

dns-list 182.1.1.33 //用户获得的DNS地址

#

aaa

authentication-scheme default

authentication-scheme abc //创建一个名称为abc的认证模版

authentication-mode radius //该认证模版认证方式为radius

authorization-scheme default

accounting-scheme default

accounting-scheme rd1 //创建一个名称为rd1的计费模版

accounting-mode radius //该计费模版认证方式为radius

domain default in default_admin

domain isp1 //创建用户域

authentication-scheme abc //该用户区域调用名为 abc的认证模版

accounting-scheme rd1 //该用户区域调用名为 abc的计费模版

radius-server rd1 //该用户区域调用名为 rd1 的radius认证域模块

local-user admin password simple admin

local-user admin privilege level 15

local-user admin service-type telnet

#

interface Vlanif250

ip address 182.40.24.249 255.255.255.0 //vlan 250的IP 地址

#

interface Vlanif510

ip address 182.40.89.1 255.255.255.0 //vlan 510的IP 地址

web-auth-server abc //该VLAN 下调用名称为abc的WEB认证服务

dhcp select global //该VLAN 下用户IP通过DHCP方式获取地址池中的地址

#

interface Ethernet0/0/0

#

in

#

interface GigabitEthernet1/0/12

description To_OA1_3/9

port link-type trunk

port trunk allow-pass vlan 2 to 4094

#

interface GigabitEthernet1/0/28

description TO-LC10

port link-type trunk

port trunk allow-pass vlan 2 to 4094

#

#

interface NULL0

#

ip route-static 182.40.9.0 255.255.255.0 182.40.24.252 //设置路由条目

ip route-static 182.40.110.64 255.255.255.192 182.40.24.252

#

user-interface con 0

user-interface vty 0 4

authentication-mode aaa

user privilege level 15

user-interface vty 16 20

#

l2-multicast-channel

#

return

---------------------------------------------

 

测试结果:

 

(供稿人:九曲)

作者:电脑维修助手 来源:不详
相关评论
发表我的评论
  • 大名:
  • 内容:
  • 电脑维修知识网(www.dnwxzs.com) © 2017 版权所有 All Rights Reserved.
  • Email:pcweixiu@tom.com 站长QQ:20567788 冀ICP备11008166号 冀公网安备 13050002001002号
  • 技术支持与报障: 电脑维修知识网